Se puede dar el caso de que al instalar un paquete con la herramienta composer te encuentres con el siguiente mensaje de error dependiendo del paquete que estés instalando, en mi caso es el mpdf.

Problem 1
- Installation request for mpdf/mpdf 8.0.0 -> satisfiable by mpdf/mpdf[v8.0.0].
- mpdf/mpdf v8.0.0 requires php ^5.6 || ~7.0.0 || ~7.1.0 || ~7.2.0 || ~7.3.0 -> your PHP version (7.4.9) does not satisfy that requirement.

Al hacer un composer install, la máquina de linux está cogiendo mi php por defecto que es el 7.4 y el cual no es soportado a la hora de instalar por ese paquete. Pero también tengo instalado el php56 y php72 mediante remi. Por lo que solo tengo que ejecutar el composer con el php correspondiente al remi php72, siendo el correcto comando de la siguiente manera:

php72 -f /usr/local/bin/composer install

Si no encuentras el composer en esa ruta, solo tiene que hacer un find para buscarlo y poner la rua correcta.